Главная Теоретический тест на понимание материала 5 урока курса

Теоретический тест на понимание материала 5 урока курса

После успешного прохождения Теоретического теста вам будут предложены практические задания для самостоятельного выполнения. После выполнения практических заданий вы сможете перейти к изучению следующего урока.

Будьте внимательны при решении теста! Если при его решении вы допустите ошибки, то сможете повторить попытку только через 1 час. Вам будут указаны вопросы, в которых вы допустили ошибки. В этом случае вам рекомендуется более внимательно изучить материалы текущего урока, так как вы усвоили материал не полностью.

 

Количество просмотров: 32946

Комментарии

  • Ура! Добил таки! Теперь напоминания о Днях рождения выводятся при открытии приложения в режиме 1сПредприятие в зависимости от константы ДнейДоДР!!!

    02 января 2014 , 00:10
  • Поздравляю, Игорь!

    03 января 2014 , 01:01
  • объясните пожалуйста 2 пункт ДЗ ни как не погу понять , что имено мне надо сделать?

    15 января 2014 , 22:22
  • Для Гусен. Вам предлагается создать новую константу Подтверждение булевого типа, а затем попробовать реализовать предложенный алгоритм. Именно попробовать и подумать почему у вас не получается (если не получается). Этот алгоритм мы реализуем на 6 уроке, но мне хотелось, чтобы вы уже понимали какая возникает проблема и почему нам делать нужно именно так... Как минимум новая константа должна быть создана у всех, кто дошел до 6 урока :) возможно, кто-то сможет реализовать требуемый алгоритм и сможет сравнить свою реализацию с моей :)

    16 января 2014 , 09:52
  • Домашнее задание серьезно обновлено! Тем, кто их выполнял ранее, следует ознакомьтесь с пунктами 3 и 4 (их раньше не было).

    16 января 2014 , 11:25
  • Здравствуйте Влад,Большое спасибо, за то что вы делаете!Только вот посмотрев комментарии(конкретно Игоря) о том что он сделал  напоминания о Днях рождения выводятся при открытии приложения в режиме 1сПредприятие в зависимости от константы ДнейДоДР.Захотелось сделать так же, но не пойму в какую сторону копать. По логике, надо вытащить из справочника в процедуру ДР сотрудника.Потом сделать функцию отъема текущей(системной) даты от ДР.И в конце процедуры, сравнить ее с константой <=ДнейДоДР(которую тоже надо как то вытащить в процедуру).Я правильно пониаю алгоритм, может не туда копаю?А то заглох в самом начале, системную дату в процедуру вытащил, а ДР из справочника не вытаскивается, дает ошибку.

    22 июля 2014 , 01:45
  • Для sarge. Отличный алгоритм. Но понадобится хитрым образом перевести дату в число (год нам будет мешать). Вообще реализовать (расчитать) какие напоминания выводить можно минимум 4 или 5 способами - ваш очень хорош, но не так прост как может показаться! Для реализации нужно будет использовать процедуру управляемого приложения (для вывода информации при старте программы) и 1 серверную процедуру (для обращения к константе и справочнику сотрудники). Но я планирую на уроке выводить эту информацию на рабочую область с помощью отчета - как у нас выводится информация по состоянию кошельков.

    22 июля 2014 , 14:22
  • Так правельно?Правда в задании не сказано что Константу нужно где то задаватьПроцедура ПередЗавершениемРаботыСистемы(Отказ)//Ответ=ПоказатьВопрос("Завершить работу с программой?",РежимДиалогаВопрос.ДаНет,,,"ВНИМАНИЕ!!!",);//Отказ=(Ответ=КодВозвратаДиалога.Нет);Подтверждение = Истина;Если    Подтверждение = ИстинатогдаОтвет=Вопрос("Завершить работу с программой?",РежимДиалогаВопрос.ДаНет,,,"ВНИМАНИЕ!!!",);Отказ=(Ответ=КодВозвратаДиалога.Нет);КонецЕсли; //Если  Вопрос("Завершить работу с программой?",РежимДиалогаВопрос.ДаНет,,,"ВНИМАНИЕ!!!",)=// КодВозвратаДиалога.Нет // Тогда// Отказ=Истина;// КонецЕсли;КонецПроцедуры 

    30 января 2015 , 10:09
  • Очень сложные задания на этот урок. Сама бы я недопетрила второе задание. А третье как ? Не могу понять у чему оно, где создать..А так до пятого урока все на одном дыхании шло, очень понятно. Большое спасибо за уроки.

    05 ноября 2016 , 21:38
  • ох, создала ))

    05 ноября 2016 , 21:48