Главная Уроки 1С Урок 5. Курс 1С для начинающих

Урок 5. Курс 1С для начинающих

На пятом уроку нашего курса 1С мы с вами начинаем знакомиться со встроенным языком 1С. В процессе урока мы с вами рассмотрим, где именно пишется программный код на языке 1с, познакомимся с операциями, которые можно выполнять с примитивными типами данных и разберем базовый синтаксис языка 1с.

Выгрузка эталонной базы, создаваемой на 4 уроке с выполненным домашним заданием 

для установки эталонной базы вам понадобится скачать платформу 1С:Предприятие 8.2 (учебная версия) или платформу 1С:Предприятие версии не ниже 8.2.15.301.

 

Программные модули конфигурации

 

Программный модуль — это своеобразный «контейнер» для размещения текстов процедур и функций на встроенном языке 1С. Эти процедуры и функции вызываться системой в определенные моменты работы системы. Программные модули не имеют формальных границ своего описания типа: "Начало модуля" — "Конец модуля".

Программные модули размещаются в тех местах конфигурации, в которых может требоваться описание специфических алгоритмов функционирования. Эти алгоритмы оформляются в виде процедур или функций, которые будут вызваны самой системой в заранее предусмотренных ситуациях (например, при нажатии кнопки в диалоговом окне и т.д.). Каждый отдельный программный модуль воспринимается системой как единое целое.

На уроке мы познакомились со следующими программными модулями:

  • модуль управляемого приложения. В данном модуле описываются процедуры (обработчики событий), которые инициализируются при старте и окончании работы системы. Например, при начале работы приложения можно обновить какие-либо данные конфигурации, вывести сообщения пользователю,  а при завершении работы  - поинтересоваться, стоит ли выходить из программы или, например, записать в базу данных время завершения работы пользователя.
  • модуль внешнего соединения. Модуль внешнего соединения срабатывает, когда запуск приложения происходит в режиме com-соединения. В этом режиме происходит программная работа с информационной базой без запуска окна приложения.
  • модуль сеанса. Это узкоспециализированный модуль, предназначенный исключительно для инициализации параметров сеанса.
  • общие модули. Общие модули предназначены для описания некоторых общих алгоритмов (процедур и функций), которые будут вызываться из других модулей конфигурации.
  • модуль объекта конфигурации. Данный модуль имеется у большинства объектов конфигурации и предназначен для обработки событий, непосредственно связанных с объектом. Например, события записи или удаления объектов, проверка заполнения реквизитов объекта, проведение документа и т.д.
  • модуль формы. Модуль формы предназначен для обработки действий пользователя с данной формой (обработка события нажатия кнопки, изменения реквизита формы и т.д.).

Более подробную информацию о программных модулях вы найдете в разделе Язык 1С: виды и структура программных модулей.

Структура программных модулей

 

Программный модуль может включать в себя три раздела:

  • область объявления переменных;
  • область описания процедур и функций;
  • основной текст программы.

В конкретном программном модуле любой из разделов (или даже все разделы) могут отсутствовать. Давайте познакомимся с разделами программного модуля более подробно:

  • область объявления переменных размещается от начала текста модуля до первого оператора Процедура или оператора Функция или любого исполняемого оператора. В этом разделе могут находиться только операторы объявления переменных Перем.

  • область описания процедур и функций размещается от первого оператора Процедура или оператора Функция до любого исполняемого оператора вне тела описания процедур или функций.

  • область основной текст программы размещается от первого исполняемого оператора вне тела процедур или функций до конца модуля. В этом разделе могут находиться только исполняемые операторы. Область основной текст программы исполняется в момент инициализации модуля. Обычно в разделе основной программы имеет смысл размещать операторы инициализации переменных какими-либо конкретными значениями, которые необходимо присвоить до первого вызова процедур или функций модуля. 

Виды переменных в программных модулях

 

Переменная – это поименованное временное хранилище одного значения, которое можно считывать и изменять в ходе выполнения программы.

Переменные бывают 3 видов:

  • глобальные переменные. Значение данной переменной можно прочитать или изменить из другого программного модуля;
  • переменные модуля. Переменная модуля доступна для чтения и записи (изменения) в любой процедуре и функции, а также в области основного текста программы данного программного модуля.
  • локальная переменная. Локальная переменная доступна лишь внутри процедуры или функции, в которой она объявлена.

Объявление переменной (в явном виде) осуществляется при помощи оператора Перем. В языке 1С переменные не обязательно объявлять в явном виде. Неявным объявлением переменной является первое ее появление в левой части оператора присваивания (знак =). Тип переменной определяется типом присвоенного ей значения. В процессе исполнения программа переменная может менять свой тип (мягкая типизация), например:

Перем1 = "Иванов"; //неявное объявление переменной, тип переменной (что она хранит) Строка

Перем1 = 32; //присвоение нового значения нашей переменной, теперь она имеет тип Число

 

Синтаксис языка 1С

 

На уроке мы с вами познакомились с базовыми (примитивными) типами значений, синтаксисом и операциями с ними. Более подробную информацию вы найдете в разделе Язык 1С: общие конструкции языка 1С. Прошу обратить особое внимание на синтаксис составных логических выражений, условий и циклов. 

Скачать конфигурацию, создаваемую на 5 уроке (без выполненного практического задания)


Итоги 5 урока

1. Мы познакомились с программными модулями и их назначением.

2. Мы рассмотрели структуру программных модулей.

3. Мы познакомились с видами переменных и их назначением.

4. Мы познакомились с примитивными типами данных и операциями над ними.

 

Практические задания по 5 уроку

 

Практические задания по 5 уроку будут вам представлены сразу же после успешного решения теоретического теста: 

Пройти тест на понимание материала 5 урока

Мы настоятельно рекомендуем вам переходить к изучению следующего урока только после выполнения всех теоретических и практических заданий по данному уроку.

К оглавлению

 

Перейти к 6 уроку

 

Количество просмотров: 69580

Комментарии

  • Влад, добрый день! Позвольте узнать, как продвигается решение об опубликовании очередного урока. Наверняка он в каком-то виде готов уже, может посмотрим и , если будут вопросы, тогда и будетвозможность его откорректировать. Этот материал один из самых интересных (о встроенном языке). Давайте решайтесь уже на его публикацию. Удачи вам!!! 

    31 октября 2013 , 20:36
  • Здравствуйте, Игорь! За праздничные дни очень постараюсь оформить 5 и 6 уроки. Я не забросил свое начинание, просто прошлый месяц получился богатым на события: это и поездка на канарские острова, и череда дней рождений, покупка земельного учатска и еще много чего... Сейчас я полон решимости выполнить все, что задумал на сайте. :) И время на это появилось!

    01 ноября 2013 , 11:13
  • Дошел до 5 урока, ожидая от Вас продолжения, что посоветуете еще почитать или посмотреть по теме? Дабы не останавливаться на долго.

    03 ноября 2013 , 00:39
  • Спасибо за предоставленный материал!Все понятно и интересно.Жду продолжения уроков!

    04 ноября 2013 , 22:46
  • а подзкажите как написать чтоб програма віводила собщение с ближайшими днями рождение

    11 ноября 2013 , 17:37
  • как писать чтоб програма віводила сообщение с ближайшими днями рождение

    11 ноября 2013 , 17:42
  • На 6 уроке мы научимся работать с датой и сделаем отчет по напоминаниям (запланированным делам на нужную дату или ближайшее время), разберем как программно работать со справочниками и вот тогда вы мне сами скажете как написать, чтобы программа выводила ближайших именинников.

    12 ноября 2013 , 09:27
  • Влад, тест не запускается. Можете поправить?

    29 ноября 2013 , 19:23
  • Для Игоря. Ссылку на тест 5 урока поправил.

    02 декабря 2013 , 14:37
  • Подскажите, а будут ли еще уроки? Закончил на 5-ом и всё ((( Все тесты пройдены

    03 декабря 2013 , 09:51
  • Конечно будут еще уроки. Мы с вами еще только начали знакомство с языком. На 6 уроке напишем полностью систему напоминаний: от сложного поведения формы до построения отчета + модифицируем наше напоминание при закрытии программы.

    03 декабря 2013 , 09:59
  • Влад, пытался написпть серверную процедуру в модуле управляемого приложения для получения константы в ДЗ.Пишет "процедура не определена. В этом модуле только предопределенные процедуры исполняются?

    18 декабря 2013 , 07:52
  • Игорь все верно! С этого мы и начнем разговор в 6 уроке. Если посмотреть материал про программные модули в разделе "Язык 1С", то мы увидим, что модуль управляемого приложения выполняется на стороне клиента, а это значит в нем НЕ МОГУТ РАСПОЛАГАТЬСЯ серверные функции и процедуры. А значит в нем мы не можем прочитать значения с нашей базы данных. Какой может быть выход? Вызывать процедуру из другого модуля, который может выполняться на сервере. 

    19 декабря 2013 , 11:21
  • Здравствуйте Влад! Программа несколько раз выдавала ошибку, что-то вроде (модуль управления не может отразить. МояПеременная=МояПеременная+С), текст проверял несколько раз, один в один, с вашим оригиналом. Полностью удалил текст и прписал сначала, всё работает, но от ошибки, осадок непонимания остался, может занете в чём дело? 

    20 января 2014 , 21:25
  • Для noperson. Чаще всего причина ошибок банальна: опечатки или орфографические ошибки, иногда забывают ставить ";" в конце оператора. Могу предложить такой способ проверки где именно ошибка: комментируйте часть кода (ставьте // перед кодом) если ошибка пропала - значит скорее всего она именно в этих закоментированных строках. 

    21 января 2014 , 15:02
  • Здравствуйте, Влад. Я понимаю,что я не по теме, но все же...Не могли бы Вы выложить на сайт конфигурацию Конвертация данных для 8.2? (2.0, 2.1 не помню точно версию). Я так понимаю она находится в свободном доступе. Я зарегистрировался на сайте ИТС через тест-драйв, скачиваю конфигурацию оттуда, но постоянно выходит ошибка, хотя другие материалы качаю без проблем. На сайте ИТС не поддерживается докачка, поэтому скачать не получается за раз 10 Мб. (интернет медленный). Был бы очень благодарен :)

    21 января 2014 , 15:24
  • Я посмотрю. 24/01/2014 к сожалению, выложит конфигурацию Конвертация данных не могу - она только для подписчиков ИТС. Возможно, сделаю несолько гайдов по ее использованию - вещь крайне полезная!!!

    24 января 2014 , 10:13
  • Добрый день. Недавно начал изучать 8.2. Понял что синтаксис и объекты разительно отличаются от 7.7. Но при это возможности также очень интригуют. Жалко что на создание урока нужно потратить больше времени чем на его просмотр. За труд вам отдельное СПАСИБО.Но вопрос у меня по пятому уроку. Понимаю что что-то не так делаю. Написал код с вопросом о завершении как на видео. Сначала все отрабатывало штатно. Но сейчас программа успевает закрыться до появления вопроса. Понимаю что куда-то  залез. Подскажите где копать? 

    20 февраля 2014 , 04:29
  • Все разобрался. Внимательнее надо быть. Вопрос снят.

    20 февраля 2014 , 04:43
  • Хотя как семерочнику мне не до конца понятен смысл строчкиОтказ = (Ответ=КодВозвратаДиалога.Нет); Переменная Отказ как я понял произвольная. Но для чего она? В каком месте начинается завершение работы?В семерке было бы такЕсли Ответ = 1 Тогда ЗавершитьРаботуСистемы() КонецЕсли; С правой стороны от равно в коде 8.2 я вижу условие. А где само завершение?

    20 февраля 2014 , 04:56
  • Прошу прощенья за форматирование.

    20 февраля 2014 , 04:57
  • Для lexnlist. 1 мысль) В 1С 8.2 при завершение пользователем работы программы (интерактивном завершении программы) автоматически системой вызываются 2 процедуры: ПередЗавершениемРаботыСистемы() и ПриЗавершенииРаботыСистемы. Разница в них заключается в том, что в процедуре ПередЗавершением мы еще можем отказаться от завершения, а ПриЗавершении уже нет. Тут мы говорим об интерактивном завершении программы (когда пользователь хочет завершить программу, а мы можем ему разрешить или запретить). Но кроме этого мы можем и программно в любой момент завершить программу с помощью команды ЗавершитьРаботуСистемы(Ложь);  2 мысль) Перейдем к интерактивному завершению программы.  Рассмотрим строчку  Отказ = (Ответ=КодВозвратаДиалога.Нет). Тут Отказ - это парамент нашей процедуры ПередЗавершениемРаботыСистемы(Отказ). Отказ имеет тип Булевый - если истина - программа завершится, если Ложь - то нет. Так вот, (Ответ=КодВозвратаДиалога.Нет) это логическое условие, где ОТВЕТ - это переменная в которую возвращается значение из диалога (вопроса), какую кнопку нажал пользователь в диалоге. Если он нажмет кнопку НЕТ, то логическое условие (Ответ=КодВозвратаДиалога.Нет) будет равно ИСТИНА. Так с помощью логического условия мы 1 строкой определяем нажал ли пользователь кнопку НЕТ и сразу же присваиваем в зависимости от этого соответсвующее значение параменту Отказ.

    20 февраля 2014 , 12:17
  • Добрый день. Спасибо за видеоуроки. С 1-го урока параллельно с тем, что Вы делаете на экране - то же самое делаю у себя в компьютере, конфигурацию создавал с нуля. По 5-му уроку вопрос. У меня стоит 1С:Предприятие 8.3 (8.3.4.437) Когда ввожу текст процедуры, которая ждёт мой ответ да или нет при выходе из программы - выскакивает ошибка : Использование модальных окон в данном режиме запрещено. Причём я эту процедуру копирую из Вашей конфигурации и вставляю в свою, то есть синтаксис верный. Запускаю Вашу конфигурацию - всё работает. Но дело в том, что сам интерфейс программы с самого начала у меня отличался от Вашего, именно интервейс платформы 1С. Понимаю, что вопрос расплывчатый, но может быть что то подскажете??

    01 апреля 2014 , 18:21
  • Александр: вместо Вопрос() и Предупреждение() в 1С 8.2 в 1С 8.3 нужно писать ПоказатьВопрос() и ПоказатьПредупреждение(). Понадобилось это только для совместимости с мобильными платформами (чтобы можно было на 1С писать приложения для Андроида, Ipad и ifon).

    02 апреля 2014 , 09:49
  • <p>Сделал код яснее и короче &mdash; и он сработал!:</p>
    <p>Процедура ПередЗавершениемРаботыСистемы(Отказ)<br />&nbsp;&nbsp; &nbsp;МойВопрос = Вопрос(&quot;Ты уходишь?&quot;,РежимДиалогаВопрос.ДаНет,5,,&quot;Внимание! Осталось 5 сек&quot;,);<br />&nbsp;&nbsp; &nbsp;
    Отказ = (МойВопрос = КодВозвратаДиалога.Нет);<br />&nbsp;&nbsp; &nbsp;<br />&nbsp;&nbsp; &nbsp;Если Отказ тогда<br />&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;Отказ = Истина;<br />&nbsp;&nbsp; &nbsp;КонецЕсли<br />КонецПроцедуры<br />&nbsp;</p>

    01 июня 2014 , 12:29
  • Процедура ПередЗавершениемРаботыСистемы(Отказ)    МойВопрос = Вопрос("Ты уходишь?",РежимДиалогаВопрос.ДаНет,5,,"Внимание!",);    Отказ = (МойВопрос = КодВозвратаДиалога.Нет);        Если Отказ тогда        Отказ = Истина;    КонецЕслиКонецПроцедуры 

    01 июня 2014 , 12:31
  • Здорово, но сокращенные логические условия могут быть трудны для восприятия новичков 1С. В любом случае я очень рад, что вы творчески подходите к материалу уроков!

    02 июня 2014 , 14:37
  • Добрый день Влад, вроде все делаю правильно, но у меня появляется окно "Использование модальных окон в данном режиме запрещено".Не понимаю где именно делаю ошибку.

    05 декабря 2014 , 16:06
  • Для u.say@mail.ru. Судя по всему вы используете версию платформы 1С 8.3, а не 8.2. Но так тоже можно, только вместо ВОПРОС и ПРЕДУПРЕЖДЕНИЕ нужно использовать ПоказатьВопрос и ПоказатьПредупреждение. В синтаксис помощнике посмотрите параметры этих функций.

    06 декабря 2014 , 09:11
  • Здравствуйте Влад, с 5 уроком возникли проблемы :{МодульУправляемогоПриложения(6)}: Ошибка при вызове метода контекста (Вопрос)Если  Вопрос("Завершить работу с программой?",РежимДиалогаВопрос.ДаНет,,,"ВНИМАНИЕ!!!",)=по причине:Использование модальных окон в данном режиме запрещено!1С выдает такую ошибку в режиме "1С:Предприятие " при закрытие окна 

    28 января 2015 , 10:42
  • Для Joker89. Вы делаете уроки на платформе 1С 8.3, а не 1С 8.2. Но ничего страшного. Вместо Вопрос() используйте ПоказатьВопрос(). Вместо Предупреждение() - ПоказатьПредупреждение(). В остальном все будет точно также.

    28 января 2015 , 11:02
  • Извените, но не помоглоОшибка инициализации модуля: МодульУправляемогоПриложенияпо причине:{МодульУправляемогоПриложения(6,7)}: Обращение к процедуре как к функции (ПоказатьВопрос)Если  <<?>>ПоказатьВопрос("Завершить работу с программой?",РежимДиалогаВопрос.ДаНет,,,"ВНИМАНИЕ!!!",)=

    29 января 2015 , 09:27
  • Для Joker89. В 1С 8.3 с показом вопроса теперь стало чуть сложнее, чем в 1С 8.2. Вы можете открыть в синтксис помощнике ПоказатьВопрос() и увидеть подробное описание. Кроме того там есть пример использования данной процедуры. Примерно будет выглядеть так:

    &НаКлиенте
    Перем ОтветПередЗакрытием;

    &НаКлиенте
    Процедура ПередЗакрытием(Отказ, СтандартнаяОбработка)
    Если ОтветПередЗакрытием <> Истина Тогда
    Отказ = Истина;
    Оповещение = Новый ОписаниеОповещения(
    "ПередЗакрытиемЗавершение",
    ЭтотОбъект);
    ПоказатьВопрос(Оповещение, “Закрыть?”, РежимДиалогаВопрос.ДаНет);
    КонецЕсли
    КонецПроцедуры

    &НаКлиенте
    Процедура ПередЗакрытиемЗавершение(Результат, Параметры) Экспорт
    Если Результат = КодВозвратаДиалога.Да Тогда
    ОтветПередЗакрытием = Истина;
    Закрыть();
    КонецЕсли;
    КонецПроцедуры

    29 января 2015 , 11:01
  • Возможно проще будет просто включить режим совместимости с версией 1С 8.2 и не заморачиваться с немодальными диалогами.

    29 января 2015 , 11:31
  • Попробуйте включить в свойствах управляемого приложения "Режим использования модальности", вкладка Совместимость...

    29 января 2015 , 18:26
  • Помогите разобраться с функцией работы со значением ДАТА - Добавить месяц.В указнном примере не понятно что к чему прибавляется и отнимается. Как это выглядит на примере если подставить? У меня выходит, что год даты умножается на 12 (!!!!!), т.е. выходит месяцы в параметре "дата", и суммируется с числом, год(ТекущаяДата) * 12. т.е. если год 1975*12, это что выйдет???  Помогите понять.Спасибо.

    29 января 2015 , 20:45
  • Вот этот примет в Синтаксис-Помощнике: ДатаРождения =СтрокаТаблицы.КонтактноеЛицо. ДатаРождения;ДеньРожденияБудущегоГода = ДобавитьМесяц((ДобавитьМесяц(НачалоДня(ТекущаяДата()), - (Год(ДатаРождения)-1)*12)), (Год(ТекущаяДата())*12));  

    29 января 2015 , 21:06
  • Здравствуйте, есть сложности с адаптацией данного урока под 8.3.Постоянно ругается: Переменная не определена (ЭтотОбъект)Оповещение = Новый ОписаниеОповещения("ОбработатьОтвет", <<?>>ЭтотОбъект); (Проверка: Тонкий клиент) Скопипастил пример Влада выше, получил такие ошибки:{МодульУправляемогоПриложения(10,1)}: Переменная не определена (ЭтотОбъект)<<?>>ЭтотОбъект); (Проверка: Тонкий клиент){МодульУправляемогоПриложения(19,1)}: Процедура или функция с указанным именем не определена (Закрыть)<<?>>Закрыть(); (Проверка: Тонкий клиент) Как это обойти? В инете практически во всех примерах ссылаются на ЭтотОбъект. 

    29 января 2015 , 23:10
  • ДЛя marinaR.Все просто. Параметры ф-ии 1: "Исходная дата", т.е. НачалоДня(ТекущаяДата()) (Сегодня это 20150131000000) 2: число месяцев, которое вы хотите добавить к исходной дате: 1975*12.Т.к. там перед параметром стоит минус, значит программа это число вычтет из количества месяцев исходной даты и вы в итоге получите 31 января 1975 г в формате 19750131000000. В с-п пример неудачный. ДеньРожденияБудущегоГода вы не получите

    30 января 2015 , 23:06
  • ДЛя marinaR. Извиняюсь, в моем примере возвращается результат 31января 0040года. Думаю смысл вам понятен в любом случае

    01 февраля 2015 , 07:50
  • Добрый день! Прошел 5 уроков, паралельно создавал конфигурацию вместе с уроком. Первые 4 без ошибок, а вот сейчас, после написания программного кода в модуле управляемого приложения система выдает ошибку:  Использование модальных окон в данном режиме запрещено! Код проверил несколько раз, все так же как и у Вас. Подскажите, пожалуйста, в чем дело?

    23 апреля 2015 , 15:08
  • Для steeshiy. Вы используете платформу 1С 8.3, а на наших уроках мы используем 1С 8.2. В принципе никаких проблем нет. Как быть в данной ситуации я подробно изложил в данной статье http://1c-uroki.ru/news/besplatnye_uroki_1S_Predprijatie_8.3Как показывает практика не зря я ее писал :) Всего наилучшего.

    24 апреля 2015 , 10:32
  • Вопрос такой. Описываю процедуру завершение работы(чтобы выводился запрос перед закрытием программы), всё повторяю точно, буковка в буковку, а при завершении работы программы выходит вопрос, если нажимать кнопку "Нет", то программа всё равно закрывается.Процедура ПриЗавершенииРаботыСистемы(Отказ) Ответ = Вопрос("Завершить ли работу программы?",РежимДиалогаВопрос.ДаНет,,,"Внимание!",);Отказ = (Ответ=КодВозвратаДиалога.Нет); КонецПроцедурыГде могла быть допущена ошибка? 

    02 августа 2015 , 15:39
  • Здравствуйте, Влад! Не могу понять в чем проблема выполняю все, как у вас в видео уроке, но после всех действий выдается сообщение об ошибке и не запускается 1С ПредпреятиеСоздаю следующее:// 1. Область объявления переменныхПерем МояПеременная, МояВтораяПеременная;  //переменная модуляПерем Третья Экспорт; //глобальная переменная   // 2. Область описания процедур и функцийПроцедура Сумма()С=15;  //локальная переменнаяМояПеременная = МояПеременная+С;   //итого 25Сообщить(МояПеременная,);КонецПроцедуры Функция СуммаЧисел(А, Б)Возврат Сумма(А+Б); КонецФункции  Процедура ПриНачалеРаботыСистемы() //Сумма();Итог = СуммаЧисел(15,10);  Сообщить(Итог);КонецПроцедуры   // 3. Основной текст программыМояПеременная = 10; //значение число, 10.7, 10+7/7*3-20, -12.6 Пытаюсь сохранить а мне выдается сообщение об ошибках {МодульУправляемогоПриложения(16,9)}: Обращение к процедуре как к функции (Сумма)Возврат <<?>>Сумма(А+Б); (Проверка: Тонкий клиент){МодульУправляемогоПриложения(16,15)}: Слишком много фактических параметров (Сумма)Возврат Сумма(<<?>>А+Б); (Проверка: Тонкий клиент) Заранее спасибо за разъяснеение  с ув. Денис.   

    06 октября 2015 , 11:06
  • Вопрос снимается, нашел свою ошибку. Прошу прощение.

    06 октября 2015 , 11:14
  • Пишет при закрытии : использование модальных окон в даном режиме запрещено. в чем причина. в каком таком режиме?

    03 декабря 2015 , 21:28
  • Гасан, это курс по платформе 1с Предприятие 8.2, а вы пытаетесь выполнять уроки с помощь платформы 1С Предприятие 8.3. Я уже писал как исправить данную ситуация и без проблем выполнять задания. Смотрите вторую часть даннго новостного материала http://1c-uroki.ru/news/besplatnye_uroki_1S_Predprijatie_8.3

    04 декабря 2015 , 10:19
  • ДД, я вообще не сог сделать д/з №5,(хотя на теорию ответил) не могли бы  Вы отправить мне на мыло (bahyt***)ответы, может хоть так вникну. Спасибо.

    28 декабря 2015 , 09:09
  • Ответы на 5 тест высланы вам на электроную почту.

    28 декабря 2015 , 09:10
  • скажите, пожалуйста, почему у меня выдает ошибку  {МодульУправляемогоПриложения(8,2)}: Неопознанный операторC<<?>>-15; //Локальная переменная

    05 февраля 2016 , 14:37