Главная Материалы Язык 1С: Справочники

Язык 1С: Справочники

 

Назначение справочников

Справочник хранит список возможных значений того или иного объекта или реквизита. Справочники используются в тех случаях, когда необходимо исключить неоднозначный ввод информации. Например, для того, чтобы покупатель, продавец, кладовщик и директор понимали, о каком именно товаре идет речь, каждый должен называть его одинаково. И в этом случае нам необходим справочник. Обычно на торговом предприятии он имеет вид прайс-листа.

Система 1С:Предприятие 8 позволяет вести практически неограниченное количество необходимых справочников. Каждый справочник представляет собой список однородных объектов: должностей, сотрудников, клиентов, товаров и т. д. Каждый такой объект называется элементом справочника.

С точки зрения пользователя, следует иметь в виду, что в Конфигураторе создается не сам справочник, как список значений, а разрабатывается заготовка справочника, его шаблон. В процессе конфигурирования описывается структура информации, которая будет храниться в справочнике, разрабатывается экранное и, если необходимо, печатное представление справочника, задаются различные особенности его поведения.

 

Реквизиты справочника (поля)

 

В качестве обязательных реквизитов каждый справочник имеет Код и Наименование. Код элемента справочника может быть как числовым, так и текстовым. Система 1С:Предприятие 8 предоставляет широкие возможности по работе с кодами элементов справочника: автоматическое присвоение кодов, автоматический контроль уникальности кода и другие.

Помимо Кода и Наименования, в справочниках системы 1С:Предприятие может храниться любая дополнительная информация об элементе справочника. Для хранения такой информации в справочнике могут быть созданы  дополнительные реквизиты (поля). Используя механизм реквизитов справочника, легко организовать, например, картотеку сотрудников. Например, справочник Сотрудники почти наверняка будет иметь реквизиты Должность, Оклад, ДатаПриема и другие. Фирма 1С предвосхитила программистов и ввела во все справочники два обязательных (предопределенных) реквизита: Код и Наименование. Действительно, практически любой объект из реальной жизни содержит эти атрибуты. Например, для сотрудников кодом выступает табельный номер, а наименованием - Фамилия, Имя и Отчество (ФИО). Кроме того, использование кодов (при использовании автоматической нумерации) позволяет с легкостью понять, какой элемент был введен раньше, а какой позже в базу данных.

 

Типы данных

 

Для каждого реквизита справочника необходимо задать тип данных, например, "число", "строка", "дата", булево (Истина или Ложь). Это базовые типы, но можно указать и сложные типы данных. Например, реквизит Должность имеет тип данных Должности. В этом случае, значения этого реквизита будут выбираться из справочника Должности. Так реализуется простейшая связь между справочниками, когда значения реквизитов одного справочника выбираются из элементов другого справочника.

 

Иерархические справочники

 

Список элементов справочника в системе 1С:Предприятие 8 может быть многоуровневым. В этом случае все строки справочника будут разделяться на 2 вида: «просто» элементы справочника и группы справочника. Группы позволяют переходить на нижележащие уровни многоуровневого справочника. Использование многоуровневых справочников позволяет организовать ввод информации в справочник с нужной степенью детализации. Элементы и группы элементов в многоуровневом справочнике можно переносить из одной группы в другую.

Подчиненные справочники

 

Между справочниками может быть установлено отношение подчиненности. В терминах реляционных баз данных, между таблицами устанавливается связь "один-ко-многим". В этом случае каждый элемент подчиненного справочника будет связан с одним из элементов справочника-владельца. Иногда можно сказать, что элементы одного справочника принадлежат элементам другого. Например, в системе может быть справочник Договора. Тогда его можно сделать подчиненным справочнику Клиенты. Это означает, что  клиент владеет договорами и у одного клиента может быть несколько договоров.

 

Табличные части

 

Начиная с версии 1С 8.0, в платформе реализована возможность для элемента справочника задавать одну или несколько табличных частей. Эту возможность рекомендуется использовать для отражения информации, связанной с данным элементом, но не имеющей собственной объектной сущности (для которых рекомендуется заводить подчиненные справочники). Например, для справочника Сотрудники могут быть заведены табличные части Образование и СоставСемьи. Работа с табличными частями похожа на работу с подчиненными справочниками за исключением того, что табличные части не могут использоваться в качестве значений реквизитов других объектов.

 

Где используется программный код для работы со справочниками?

 

Так как для выполнения программного кода нам необходимо обращаться к базе данных, данные куски программного кода должны размещаться в процедурах и функциях (или модулях) выполняемых на стороне сервера. Дополнительную информацию смотри в разделе О программных модулях.

 

1. Ссылка на справочник

 

Для работы со справочником из какого-либо модуля требуется сначала создать ссылку на этот справочник.

СпрСотрудники = Справочники.Сотрудники; // или 2 вариант
СпрДолжности = Справочники["Должности"];

 

2. Создание и запись нового элемента справочника

 

НовЭл Справочники.Сотрудники.СоздатьЭлемент();
НовЭл.Наименование = "Петров Петр Петрович";
НовЭл.Оклад = 25000;
НовЭл.Записать(); // именно в этот момент происходит запись в базу данных

 

3. Создание и запись новой группы справочника (для иерархического справочника)

 

Нов = Справочники.Сотрудники.СоздатьГруппу();
Нов.Наименование = "Работающие";
Нов.Записать();  
// или 2 вариант 
Нов = Справочники["Сотрудники"].СоздатьГруппу();
Нов.Наименование = "Работающие";
Нов.Записать();

 

4. Поиск элемента справочника

 

// если элемент найден, то он возвращается, иначе возвращается значение Неопределено

СпрСотр Справочники.Сотрудники;

НайденныйСотр = СпрСотр.НайтиПоКоду(123);   //ищем по коду
НайденныйСотр = СпрСотр.НайтиПоНаименованию("Иванов Иван Иванович"); //по наименованию
НайденныйСотр СпрСотр.НайтиПоРеквизиту("Оклад", 5000);    //по реквизиту

//далее нужно проверить найденное значение

Если НайденныйСотр = Неопределено Тогда
    //элемент не найден
КонецЕсли;

5. Удаление элемента справочника

 

СпрСотр Справочники.Сотрудники;

СпрСотр.Удалить(); //непосредственное удаление текущего элемента справочника

СпрСотр.УстановитьПометкуУдаления (Истина); //пометка на удаление
СпрСотр.УстановитьПометкуУдаления (Ложь); //снять пометку на удаление

//можно проверить, помечен ли элемент на удаление
//свойство ПометкаУдаления имеет тип Булево (Истина или Ложь)

Пометка = СпрСотр.ПометкаУдаления; //обратите внимание: это свойство
Если Пометка = Истина Тогда
    //элемент помечен на удаление
КонецЕсли;

 

6. Перебор элементов справочника


Выборка = Справочники.Сотрудники.Выбрать();
Пока Выборка.Следующий() = 1 Цикл // начало перебора элементов справочника в цикле
//действия с очередным элементом ...
Сообщить("Сотрудник " + Выборка.Наименование);
КонецЦикла;

 

7. Родитель. Перебор элементов внутри группы.


Группа в терминах 1С - это "родитель".

СпрСотр Справочники.Сотрудники;
ГруппаРаботающие = СпрСотр.НайтиПоНаименованию("Работающие");
Выборка = СпрСотр.Выбрать(ГруппаРаботающие);
Пока Выборка.Следующий() = Цикл
   //действия с очередным элементом
   Сообщить("Сотрудник " Выборка.Наименование);
КонецЦикла;

 

8. Владелец. Перебор элементов справочника, принадлежащих элементу другого справочника.


Один справочник подчинен другому справочнику, например справочник НалоговыеЛьготы подчинен справочнику Сотрудники.

Выборка = Справочники.НалоговыеЛьготы.Выбрать( ,Сотрудник); //тут сотрудник - ссылка на элемент справочника сотрудники
Пока Выборка.Следующий() = Цикл
   //действия с очередным элементом
   Сообщить("льгота " + Выборка.Наименование);
КонецЦикла;


9. Транзакция


При создании множества элементов справочника для ускорения работы можно заключить цикл в транзакцию. При этом реальное создание всех элементов произойдет только по команде ЗафиксироватьТранзакцию(). При использовании транзакций действие будет либо выполнено целиком (созданы все элементы справочника), либо не выполнено совсем (в случае какого-либо сбоя не будет создано ни одного нового элемента, все останется также, как до запуска транзакции). Транзакции широко применяются в банковской сфере. Ведь никто не хочет, чтобы при отправке денег, они благополучно списались с вашего счета, но из-за какого-либо сбоя не дошли до адресата.

СпрСотр Справочники.Сотрудники;
НачатьТранзакцию();

Для Ном = 1 По 100 Цикл
   Нов = СпрСотр.СоздатьЭлемент();
   Нов.Наименование = "Новый " + Строка(Ном);
   Нов.Записать();
КонецЦикла;

ЗафиксироватьТранзакцию();

Количество просмотров: 84664

Комментарии

  • <p>Да, выборка в п.6 слегка запоздала. А так ценный материал...</p><p>&nbsp;</p>
    14 января 2014 , 18:30
  • <p>А если надо перебрать все элементы справочника по всем группам?</p>
    18 января 2014 , 20:55
  • <p>И еще вопрос: Как в 8.3 реализована работа с общими реквизитами, похоже, что их убрали?</p>
    18 января 2014 , 21:27
  • <p>Игорь, в 1С 8.3 общие реквизиты остались на своем месте. Предполагаю, что они могут быть скрыты, если в настройках конфигурации выбрать режим совместимости с 1С 8.2.13 (не проверял сам).</p>
    20 января 2014 , 10:07
  • <p>Для перебора всего справочника по группам это конструкция из 6 примера. В выборке будут и группы и элементы. Если группы не нужны или мы просто хотим узнать текущий объект это группа или элемент, то можем использовать такую проверку: Если Выборка.ЭтоГруппа()=Истина тогда. Для исключения групп из выборки можем дописать так:&nbsp;Если Выборка.ЭтоГруппа()=Истина тогда продолжить; КонецЕсли; В синтаксис помощнике можно посмотреть подробное описание метода&nbsp;<span style="font-size: 1em; line-height: 1.5; border: 0px none; border-collapse: collapse; font-family: 'Lucida Sans Unicode', 'Lucida Sans', 'Lucida Grande', Verdana, Geneva, sans-serif; text-align: justify; color: rgb(0, 0, 255);">Выбрать</span><span style="font-size: 1em; line-height: 1.5; border: 0px none; border-collapse: collapse; font-family: 'Lucida Sans Unicode', 'Lucida Sans', 'Lucida Grande', Verdana, Geneva, sans-serif; text-align: justify; color: rgb(255, 0, 0);">(</span><span style="font-size: 1em; line-height: 1.5; border: 0px none; border-collapse: collapse; font-family: 'Lucida Sans Unicode', 'Lucida Sans', 'Lucida Grande', Verdana, Geneva, sans-serif; text-align: justify; color: rgb(255, 0, 0);">). У данного метода много параментов.</span></p>
    20 января 2014 , 10:17
  • <p>А как изменять реквизиты в справочнике программным путем? Например, мне нужно массово изменить реквизит &quot;Дата рождения&quot; в справочнике &quot;ФизЛица&quot; у всех элементов. Думаю, нужно написать обработку, где я задаю новое значение &quot;даты рождения&quot;. А дальше не совсем пойму, что делать.</p>
    02 февраля 2016 , 16:58